VisualStudio に関する投稿を表示しています

Windows7でTypeScript0.9のVSプラグインがインストールできなかった

この記事は公開されてから1年以上経過しており、情報が古い可能性があります。

【前提】
・Windows7 Professional x64 (サービスパックなし)
・VisualStudio 2012 Professional

【問題となったもの】
・TypeScript 0.9.1.1
http://www.microsoft.com/en-us/download/details.aspx?id=34790

System Requirementsを読むと、win7とvs2012組み合わせでもいけそうなことが書いてある。
が、なぜかインストール出来ない。

ググってみると、WebEssentialを入れろとか、ログを見せてあー再起動ねとか、
あれこれあったような気がしますがどれもダメ。

【解決】
ダメ元でWindowsUpdateして、SP1を入れたところ、インストールできた。

System Requirementsに書いておいてくれ頼む...

VisualStudio2010でもTypeScriptが書きたい!

この記事は公開されてから1年以上経過しており、情報が古い可能性があります。

TypeScriptというMS製のaltjsが最近でてきまして。
それを使えるのがVS2012からっぽいので、はてさてどないしましょうか。という。

すなおに2012を入れるとか、VSをあきらめてnpmで入れるとか、すればいいのですが、いろいろあってまだ2010のほうがいいなーと状況で、さてどうしようか、というものです。

TypeScript for Visual Studio 2012より、"TypeScriptSetup.0.8.0.msi"をDL。
DLしたインストーラを7zipで展開して、*.visx_FILEを*.visxにリネーム。
*.visxファイルを実行し、インストールすればVS2010でもプロジェクトを作ったり、tsファイルを追加したり、ビルドできたりできます。
そのあとで、0.8.*をDLして普通にインストールすると、そのバージョンのコンパイラが使えます。
(0.8.*でこれを実行しようにも、visx_FILEがなかったようなあったような…確認不足ですんません)

新規TypeScriptプロジェクトを作るには
「新しいプロジェクト」->「VisualC#」->「HTML Application with TypeScript」
tsファイルの追加には
「新しい項目の追加」->「VisualC#」->「TypeScript File」
という、ぱっと見どこにあるのかわからなかったのでメモ。

そういえば、今後でジェネリクスが入ってきたり、非同期(async/await)が入ってくるらしいです。(ロードマップ参照)
インテリセンスでバリバリ行けてしまいますし、このままTypeScript充ですかね…。ひょええええ。